
Guide to moving Windows XP default folders 
from the system partition to a dedicated data partition 
 
General: 
 
When installing an operating system, it is common to leave the hard disk as a single partition 
[C:]. Splitting the hard disk into two partitions, [C: and D:] is good strategy. It gives you the 
opportunity to separate user data from the operating system and program files. This simplifies 
backing up user data as well as restoring/reinstalling the system without losing user data. An 
extension of this strategy is to install a second hard disk and partition it for backups of user 
data and images of the system partition. 
 
This guide does not detail how to partition a hard disk. It requires a separate guide and several 
are available on the Internet. 
 
This guide is valid for Windows XP Professional, on which it was devised and for Windows 
XP Home. 
 
The default Windows XP folders, containing user data, are: 
 
- My Documents (including a number of subfolders within it), 
- Favorites, 
- Store Folder location for Email in Outlook Express (several files), 
- Address Book (two files) 
 
You will find instructions on how to move these default Windows XP folders from their 
respective default location on C: into the folder(s) of your choice on D: below: 
 
Windows Explorer (WE): 
 
Some folders are moved in WE. To open WE, click Start > right click on My Computer > 
Explore. 
 
You have to (temporarily - do not forget to change back when done) configure WE to show 
hidden files and folders. To do that, in WE, click Tools > Folder options > View Tab > 
Advanced settings > find ‘Hidden files and folders’ and click the radio button to show hidden 
files and folders. 
 
Moving folders (and files) using the mouse: 
 
Left click drag-n-drop means that the left mouse button should be held down while dragging 
and released when dropping in the new location. 
 
If this is done from one location to another on the same partition, the folder will be moved. 
 
If this is done from one partition to another, the folder will be copied and you do not want 
that! 
 



Instead, you will use right click drag-n-drop. When the mouse button is released in the new 
location, a menu will appear with four choices: Copy, Move, Create shortcut and Cancel. You 
want to Move! 
 
Another way to do it (safer, easier and actually my recommendation) is to right click (not 
hold) on the folder, a menu will appear with a few choices; choose ‘cut’. Navigate to the new 
location, right click (not hold) in any free space, the menu will reappear; choose ‘paste’. 
 
Multiple users: 
 
If you have created a single user account, creating a folder on D: for the single account is 
optional, but if there is a chance that users will be added in the future, create the folder now. It 
will make it easier when adding users. The instructions assume that a separate folder, 
D:\Name-1, has been created for the single account. If you choose to not create the folder, you 
should substitute D:\ for D:\Name-1 in the instructions. 
 
If you have created more than one user account, you have to create a separate folder on D: for 
each account, e.g. D:\Name-1 and D:\Name-2, etc. 
 
The procedure of moving the folders has to be repeated for each account, logged in to each 
account in turn. You must be logged in to the user account you are working with. Never move 
any folders or make any changes to Name-X if you are logged in to Name-1. 
 
I recommend disabling Fast User Switching for the duration of the work. To do that, click 
Start > Control panel > User accounts > ‘Change the way users log on or off’ and uncheck the 
box for ‘Use Fast User Switching’. 
 
Create a folder: 
 
In WE, click on D: in the left hand pane to highlight it. The right hand pane will show the 
files and folders on D: but if you are starting fresh, it will be almost empty. 
 
Depending on how you have configured WE, hidden files and folders (and hidden system 
files) may be visible. A hidden file or folder can be distinguished by a ‘pale’ appearance 
compared to a ‘normal’ file or folder. Leave them alone! 
 
Right click (not hold) in any free space in the right hand pane and a menu will appear; choose 
New > Folder. The folder will appear with the name ‘New Folder’ in grey which you should 
rename to Name-1 (or Name-2, etc.). 
 
After highlighting the new folder, e.g. Name-1, in the left hand pane, the Address Bar above 
the panes should read ‘D:\Name-1’. If the Address Bar is not visible click on View > Toolbars 
and click on Address Bar. 
 
 
Move the My Documents folder: 
 
The default location of the My Documents folder is: 
 
C:\Documents and Settings\Name-1\My Documents 



The first thing to do is to create a new My Documents folder in D:\Name-1. 
 
Open WE, navigate to D:\Name-1 and highlight ‘Name-1’ in the left hand pane. Right click in 
any free space in the right hand pane > New > Folder > name it ‘My Documents’. Close WE. 
 
Click Start > right click My Documents > Properties. In the Target Tab (should open in that 
tab) click Move > click on the + sign next to My Computer > click on the + sign next to D: > 
click on the + sign next to Name-1 > click on My Documents > OK (window closes) > Apply 
and when asked if you want all subfolders and contents to be moved, the answer is YES to all 
> OK. 
 
To verify that the move was successful, click Start > right click My Documents > Properties  
and verify that the path to the target is D:\Name-1\My Documents. 
 
Open WE and navigate to C:\Documents and Settings\Name-1. Highlight Name-1 in the left 
hand pane - the subfolder My Documents should no longer be there. 
 
Navigate to D:\Name-1\My Documents and highlight My Documents in the left hand pane. 
The subfolders My Music and My Pictures should be there. (That is for a virgin system but if 
it has been used, there may be other folders and files too.) Close WE. 
 
You do not have to edit the registry. It is automatically updated to reflect the change. 
 
Restart the computer. 
 
 
Move the Favorites folder: 
 
The default location of the Favorites folder is: 
 
C:\Documents and Settings\Name-1\Favorites 
 
Open WE and navigate to C:\Documents and Settings\Name-1\ and highlight ‘Name-1’ in the 
left hand pane. In the right hand pane, right click on Favorites and from the menu which 
appears choose ‘cut’. 
 
Navigate to D:\Name-1 and highlight ‘Name-1’ in the left hand pane. Right click in any free 
space in the right hand pane and from the menu which appears choose ‘paste’. 
 
Highlight Favorites in the left hand pane. When it opens the Address Bar should read 
D:\Name-1\Favorites. The subfolder Links and a few shortcuts should be there. (That is for a 
virgin system, but if it has been used there may be other folders too and several shortcuts.) 
 
Navigate to C:\Documents and Settings\Name-1\ and highlight ‘Name-1’ in the left hand 
pane. The subfolder Favorites should no longer be there. Close WE. 
 
You do not have to edit the registry. It is automatically updated to reflect the change. 
 
Restart the computer. 
 



Move the Store Folder location for Email in Outlook Express: 
 
The default storage location is: 
 
C:\Documents and Settings\Name-1\Local Settings\Application Data 
\Identities\{GUID}\Microsoft\Outlook Express 
 
where {GUID} is a unique alphanumeric number. 
 
(Moving the Address Book will be handled separately, but you will create the associated new 
folder(s) now.) 
 
I suggest creating a separate folder with subfolders on D: for these files. 
 
Open WE, navigate to D:\Name-1 and highlight ‘Name-1’ in the left hand pane. Right click in 
any free space in the right hand pane > New > Folder > name it ‘Email’. 
 
Highlight Email in the left hand pane. Right click in any free space in the right hand pane > 
New > Folder > name it ‘Outlook Express’. 
 
Right click again in any free space in the right hand pane > New > Folder > name it ‘Address 
Book’. 
 
Highlight Outlook Express in the left hand pane. The Address Bar above the panes should 
read D:\Name-1\Email\Outlook Express. 
 
Highlight Address Book in the left hand pane. The Address Bar above the panes should read 
D:\Name-1\Email\Address Book. Close WE. 
 
Open Outlook Express. 
 
Click Tools > Options > Maintenance Tab > Store folder button > Change > click on the + 
sign next to My Computer > click on the + sign next to D: > click on the + sign next to Name-
1 > click on the + sign next to Email > click on Outlook Express > OK (window closes) > OK 
> OK. 
 
Close Outlook Express. 
 
You do not have to edit the registry. It is automatically updated to reflect the change. 
 
Restart the computer. 
 
To verify that the move was successful, open Outlook Express, Click Tools > Options > 
Maintenance Tab > Store folder button > verify that the path to the target is D:\Name-
1\Email\Outlook Express. 
 
Open WE and navigate to C:\Documents and Settings\Name-1\Local Settings\Application 
Data\Identities\{GUID}\. There should no longer be any folders Microsoft\Outlook Express. 
Close WE. 
 



Move the Address Book: 
 
The Address Book is created by the system the first time the Address Book is opened. If you 
have not been there, open Outlook Express, open the Address Book and close them both 
again. 
 
The default location of the Address Book is: 
 
C:\Documents and Settings\Name-1\Application Data\Microsoft\Address Book 
 
In this case, you are not moving the folder itself but the two files (Name-1.wab and Name-
1.wab~) within it. It is also a bit more complicated since you will have to edit the registry 
manually. 
 
Before proceeding, learn how to backup and restore the registry in: 
 
[URL=http://support.microsoft.com/kb/322756/en-us]How to back up, edit, and restore the 
registry in Windows XP and Windows Server 2003[/URL] 
 
In the section ‘Move the Store Folder location for Email in Outlook Express’ you created a 
new Address Book folder located in D:\Name-1\Email\Address Book. (If not, go to that 
section of the guide and take it from there.) 
 
Verify that Outlook Express and the Address Book are closed. 
 
Open WE and navigate to: 
 
C:\Documents and Settings\Name-1\Application Data\Microsoft\Address Book  
 
and highlight Address Book in the left hand pane. In the right hand pane, right click on Name-
1.wab and in the menu which appears choose ‘cut’. 
 
Navigate to D:\Name-1\Email\Address Book, and highlight Address Book in the left hand 
pane. Right click in any free space in the right hand pane and in the menu which appears 
choose ‘paste’. 
 
Repeat the procedure for ‘Name-1.wab~’. 
 
Both files can be moved at the same time by Ctrl clicking the second file. (Ctrl clicking means 
hold down the Ctrl key on the keyboard and click.) In the right hand pane, first click on 
Name-1.wab, then Ctrl click on Name-1.wab~. Both should become highlighted. Right click 
on the two files and in the menu which appears choose ‘cut’. Proceed as outlined above to 
paste in the new location. 
 
Close WE. 
 
Do not open Outlook Express or the Address Book! 
 
 
 



Now, it is time to edit the registry: 
 
To be able to edit the registry, the user account must have administrator privileges. ‘Name-1’ 
should by default have such privileges but ‘Name-2’ and other users may not. 
 
To check and (temporarily - do not forget to change back when done) change the privileges, 
log in to ‘Name-1’. Click Start > Control panel > User accounts > Change an account > 
choose ‘Name-X’ > Change account type > click the radio button for ‘Administrator’ > click 
on the ‘Change button’ > OK and exit your way out. 
 
Click Start > Run > type: regedit > OK > the Registry Editor will open. 
 
If the Registry Editor has never been run, My Computer should be highlighted in the left hand 
pane. If not, highlight anything in the left hand pane and press Shift + Home (at the same 
time) on the keyboard. My Computer should be highlighted after that. It is important that My 
Computer is highlighted at the start of a search. If it is not, the search will not start from the 
beginning of the Registry. 
 
Click Edit > Find and type in ‘wab file name’ in the ‘Find what’ dialogue box > click Find 
Next (it will take some time). The search should take you to the key: 
 
HKEY_CURRENT_USER\Software\Microsoft\WAB\WAB4\Wab File Name 
 
In the right hand pane, right click on the value (Default) > click Modify and the Edit String 
dialogue box appears. The Value data field should read: 
 
C:\Documents and Settings\Name-1\Application Data\Microsoft\Address Book\Name-1.wab 
 
Change it to: 
 
D:\Name-1\Email\Address Book\Name-1.wab 
 
Highlight anything in the left hand pane, press Shift + Home (at the same time) and My 
Computer should be highlighted. 
 
Close the registry editor and restart the computer. 
 
Open Outlook Express and the Address Book and close both again. 
 
To verify that the move was successful, open WE and navigate to C:\Documents and 
Settings\Name-1\Application Data\Microsoft\Address Book. There should be no files. Close 
WE. 
 
(If the edit of the registry should be unsuccessful or if Outlook Express and/or the Address 
Book were opened before the computer was restarted, the files will go back to the original 
location.) 


